Friday, June 4, 2010

Honda Express Oil Pump | How to Remove, Inspect, Repair, Install 1978 NC 50 Oil Pump Scooter


Honda Express Oil Pump video is done! I have edited the video and uploaded it to YouTube. You can view the entire video below. The video will take you through (step-by-step) process of removing your Honda Express Scooter's oil pump. I have tried to interject helpful tips and information during the video to help you with inspecting and reinstalling your oil pump. It is good practice to check your oil pump several times throughout the lifetime of your nc 50 moped. It helps with moped performance and prevents the oil pump for malfunctioning and seizing the engine. Good Luck!

 

Checkout my other YouTube video on How to Remove Honda Express Moped Carburetor.

3 noped comments:

Trevor said...

I have had a problem with my moped a 1980 Honda Express II, oil has been leaking by my oil pump and into my carburetor, what is letting it leak by? i cant seem to figure it out because everything looks to be in good condition in the pump.

steve said...

I saw a comment in the service manual somewhere that there is a check valve in the fitting at the intake that holds back the oil until it is pumped out of the pump into the intake so it shouldn't just drain from the tank throught the pump into the engine.

Kennedy said...

Hello, I have a few questions for you experts. I picked up an 81 express that has been through A LOT of hard times and converted to premix. It also came with a box of parts some from the same year some not. It didn't run or anything when I got it but I have been working on it and thought I would see if what I am doing is totally wrong. The previous owner had put a different year carb on it, pulled the shaft out of the oil pump (which looks to be from a different year as well), and capped one of the lines. I have put a shaft back into the oil pump (after both got a thorough cleaning), cleaned the carb, changed the inlet pipe to accommodate the different oil pump's delivery method of oil, changed the oil in the transmission (sadly they had neglected this and only of about 1/4th of a cup of foul, nasty stuff came out), and made sure the manual choke lever and throttle cable now function properly. The express now starts on the first kick every time cold or not (makes me believe some tuning needs to be done to accommodate using the choke in cold weather), however, it bogs down after a normal albeit slight acceleration. It will top out about 12mph, and I have yet to do much in the ways of tuning the fuel and air mixture. - as recommended as a fix for similar issues. Before I go down that road I thought I would post this for consideration of the frank-no-ped that I am working on. Are the engine specs throughout the years similar enough that my retro fittings will properly lubricate the piston, chamber, etc? I wasn't sure about this and noticed something that bothers me about the oil delivery. The line to the inlet pipe never seems to stay free of air and when I had the lines fully bled, the oil would just run out of the line into the pipe. Then when I have it running, the oil takes a long time to push through to the pipe again making me wonder if things are being properly lubricated. Is there anything to worry about with this and should I move on to adjusting the air and throttle stop screws or should I focus on the oil issues? Any advice would be appreciated. P.S. Thanks for all of the helpful information you have on your site, I wouldn't have gotten this far with out it!

Post a Comment | Feed

Post a Comment